Amazon tablet update not working

Both my Amazon tablets were working fine. Today they both updated to Home Remote and when I start home remote
“Value cannot be null.
Parameter name: key”

I have tried reloading the hrp, but I get the same error.

Just downloaded the desktop designer and the hrp runs fine there. I resaved the hrp with the new version still the same issue.
Not really sure on how to debug this, any help would be much appreciated!


Can you please email me your project? Send it to

Please strip out any info you do not want to share.

You need to delete the EventTrigger on the ClockBrowser control in Home.xaml. Or you need to assign an Event to it. It’s currently null so that’s why you are having issues loading the page. I will fix this in the next release so that it’s able to ignore these unassigned EventTriggers. For the time being though, you are going to need to update that control.

For anyone else experiencing issues with the latest updates, please update the Designer to version 4.1.3.X. Then open your project in the Designer & Save it. Send the saved file to the apps & it should work. When you Save, the Designer will automatically correct these triggers for you so it doesn’t have to be done manually.