Blue Iris http Streams

Okay… I’m quite new to this, but am fairly competent with technology in general. I’m trying to connect to my Blue Iris streams and not having much luck at all.
I’ve set my local connections to be anonymous… I’ve tried a user and password. Nothing!

I’m using the URL http://ip_address:port/mjpg/CamShortName/video.mpjg and http://ip_address:port/mjpg/CamShortName.

Both streams work fine in Chrome and VLC on my android tablet… but I keep getting the error that I need to provide a valid JPEG, MJPEG or H264 URL. I’m stumped. Does anybody know?

You’ve got a typo in your URL. It should by “.mjpg”, not “.mpjg”. Blue Iris streams are definitely compatible & have been used on a few projects I’ve worked on.


Yeah… that was just a typo on my part when I was posting. I still get the failed to validate URL. I’ve tried all combinations of admin users/passwords, etc.

I can still stream on any other device, just won’t work when adding the stream in Home Remote. I know it should work, but it isn’t.
Firewall issue? But then it should work in vlc or chrome.
Maybe issue with version 4 on Blue Iris?
Seriously stumped.

Have you tried adding it to the Home Remote Android & iOS apps? Can you add it to those apps? Or is it only the Home Remote Designer that it’s not working?

Designer and Android

I’m running designer on the same computer that I’m running Blue Iris on, so I tried localhost as well. It’s really weird. I’ve checked all of the settings

Hold on. I just tested my Blue Iris streams & they are still working but I can’t add a new camera using the new device dialog. Let me look into into that to see what’s going on.

For the time being, open the attached project in a 2nd Designer instance & copy-paste my Camera1 device into your project. Then just update the IP address in the Properties pane.

BlueIrisCamera.hrp (96.2 KB)

This will be fixed in the next release 3.10.2. Should have it posted in a day or 2.

Another work around would be to initially add it with RTSP instead of HTTP. RTSP streams are not validated on that dialog. What you could do is add any RTSP URL, then after the device is added go into the properties and manually update them.

That is fantastic. I’ll give it a go.

3.10.2 has been uploaded so you no longer need my work arounds.

Perfect. Thanks… but the workarounds did the trick! I now have cycling cameras!