Ewelink stopped working

Hello @bill
Today ewelink devices stopped working in THR.
I tried to add the Ewelink service again and there is an authentication failure. Could you check what happened?
the following message appears: “Sign:oauthClient enable invalid”
(the devices in the ewelink app work fine)


same to me…at first I thought i got a bad password.

1 Like

Today stoped ewelink device working
message appears: “Sign:oauthClient enable invalid”
Any idea to solve problem

1 Like

Same to me also here in Greece

Same, how do we fix it .

It looks like they made a major API change. This could take some time to fix.

One solution would be to connect eWeLink through a 3rd party service. SmartThings & Home Assistant both provide eWeLink access. What you could do is connect eWeLink to either one of those services & then link SmartThings or HA to Home Remote.

Dear Bill,
I have the same problem but is strange we not work on android ( message Sign:oauthClient enable invalid ) but we work with IOS.
How many time do you think for solve the problem ?
Many thanks

I’m not sure why it would work on one platform but not the other. So you’re saying it works in the Home Remote iOS app but not the Home Remote Android app?

For me the problem occurred first on ios. After that I tried on android and pc, same error!

Today is the same with android and Ios…

I check is working with ewelink only if is in the same wifi.
If you are out of this and you using data by telefono don work.
Please solve the problem.

1 Like

The Ewelink platform does not allow the THR login.
Now I have to access Ewelink with Smartthings, at least it’s working. .

Hi news about the problem ?

Read the solution I proposed earlier in the thread. It’s going to take some time for me to get this working their new API so I suggest you use the work-around I mentioned for the time being.

Same here in Singapore as well. It still works while on LAN, but it won’t work remotely.

Removing device and adding back won’t work because there isn’t an option to choose eWelink anymore!

Adding/resyncing the eWeLink devices required remote/cloud access. When they changed their cloud API that broke this. That is why it was removed from the “Add a device” menu.

Same problem,
with IOS, I look for update
thank you

Smarthings is a good temporary fix to ewelink, only down side is smarthings does not show ewelink motion sensors only door contacts.

The same is happening to me here in Brazil. The interesting thing is that I can just use THR with Ewelink in my home network, but I´m having this same message error while using 4G.