Fibaro Home Center 3

Hi All,
I migrated from Fibaro HC2 to HC3. I wanted to use Home Remote but now I have a really strange behavior: Home Remote recognizes HC3 and sees all devices and scenes. When I add the buttons etc. to the screen I have exactly two devices which work (one switch and one RGBW controller) and the rest create a 404 (switches) and a 501 (scenes).
Should this work with HC3 and if yes, where could the problem be? And if no, what can I do to help to make this happen?
Thank you

There have been a few reported issues with HC3. No, it has not been thoroughly tested. I don’t even think that controller is available here in the US yet. I submitted a support ticket the other day to Fibaro requesting documentation on the new HC3 API because, from what I can tell, nothing has been published yet.

I should be able to get your switches working. Their “device” API is sort of self documenting so I should be able to look at your JSON data to determine what’s going on with your switches. Can you send me the JSON returned from the URL below? You can email it to me at Let me know exactly which switches aren’t working. I don’t need all. Just 2 or 3 will be enough.

I know scenes currently do not work as @hrannar has mentioned in another topic. It appears their “scene” API has some pretty significant changes. I suggested to him to try going to the Fibaro forum to see if he can get help there. Most commands are simple HTTP GET requests that can be easily tested just by copying & pasting a URL into the Chrome address bar. In one of the links he shared a user suggests that we need to use a HTTP POST but that didn’t appear to work either. To send a POST you’ll need to use a tool like CURL or POSTMAN. Both are pretty easy to use. If either of you can find out for me exactly what needs to be sent & have verified it works, just let me know, then I’ll update the app.

Hi Bill,
thank you for the fast response.
I have seen the post. There is actually a Swagger page describing the api. I downloaded Devices and Scenes. Let me know if you need anything else. Is there a possibility to map Quick Apps (formerly Virtual Devices) as well?
I will send you a PM with the link to a zip where you can find the JSON list of my devices and the two Swagger pages.
135 and 554 (even including the color mixer) work like a charm. The rest does not seem to work for sure 575, 501, 582, and 589 and a lot of other devices

That Swagger doc you sent indeed shows that it wants a POST. What it doesn’t show is the Content for the POST. Typically, POST commands require some content. Since it doesn’t list anything, I’m going to assume we can just send it an empty JSON object. Can you please test it in CURL?

curl --header "Content-Type: application/json" --request POST --data '{}' -u username:password

…just replace with your IP address & username:password with your actual credentials.

…if you are using Windows 10, CURL should already be installed. So just copy & paste it into the command prompt.

Did all that and added a trace to scene 25. Somehow nothing seems to happen. Curl (which I do not know) does not come back with an error but the scene does not execute

I used Swagger now. With this body it works:

Good. Making some progress then.

Does this command work in CURL?

curl --header "Content-Type: application/json" --request POST --data '{"args":{}}' -u username:password

No success. Is there a way curl gives me a respnse?

Add the verbose option

curl --verbose --header "Content-Type: application/json" --request POST --data '{"args":{}}' -u username:password

Or maybe we have to include that “alexaProhibited” part too. Try this:

curl --verbose --header "Content-Type: application/json" --request POST --data '{"alexaProhibited":true,"args":{}}' -u username:password

Oh, well… It is probably too late. It helps if the user has the access rights to the scene, right? Swagger was logged in as an admin…
I changed access control but still get a 403. Do you have an idea? I checked user and password. I have a number and a special character in the password… As required by Fibaro

I’m not sure. We are probably going to need some clarification from Fibaro on exactly what is all needed.

Can you submit a support ticket & email them?

Also might help to post in the Fibaro forum as well. There are more people having this problem. Add to this discussion & let them know you too aren’t able to trigger scenes through the API either.

Will do tomorrow morning. How do you see devices?

I do see the problem with those. If you look at the JSON file, devices “575, 501, 582, and 589” don’t have any actions defined. Earlier when I said that the “devices” API was kind of self-documenting, what I was referring to were the available “actions” a device has. Those Ids you shared with me earlier all have a set of actions that looks like this:

"actions": {}

Typically for a switch, at minimum you’d see this:

"actions": {
            "turnOff": 0,
            "turnOn": 0

I’m not sure how we are supposed to control these switches if they don’t have “turnOn” & “turnOff” commands.

Are these normal ZWave switches or where did you get them from? If these are from a 3rd control Plugin you may have to ask the author how to control these. Without the necessary “turnOn” & “turnOff” actions, I’m not sure how to do that.

Can you also test those switches in CURL?

curl --verbose -u username:password

These can also be tested in the web browser directly too.

Do either of these commands work?

They are normal ZWave switches from Fibaro. However, I experienced some issues after the migration from HC2 to HC3. After a soft-reconfiguration and after deletion of the HC in the Home Remote app and re-adding it, the problem is fixed.
So, I guess a need a soft-reconfiguration or these devices and then 80% is fixed for me :slight_smile:
Scenes and QA/Virtual Devices are the ones which would make me ultimately happy
Thank you!!!

We are getting closer to it. I did a Soft Reconfiguration of all the devices and this seems to fix it. However, interestingly I do not see all the devices in the Home Remote designer. E.g.
{“id”:778,“name”:“Licht Büro Roger”,“roomID”:233,“view”:[{“assetsPath”:"/dynamic-plugins/com.fibaro.binarySwitch/assets",“jsPath”:"/dynamic-plugins/com.fibaro.binarySwitch",“name”:“com.fibaro.binarySwitch”,“translatesPath”:"/dynamic-plugins/com.fibaro.binarySwitch/i18n",“type”:“ts”}],“type”:“com.fibaro.binarySwitch”,“baseType”:“”,“enabled”:true,“visible”:true,“isPlugin”:false,“parentId”:419,“viewXml”:false,“configXml”:false,“interfaces”:[“energy”,“light”,“power”,“zwave”,“zwaveMultiChannelAssociation”,“zwaveSwitchAll”],“properties”:{“pollingTimeSec”:0,“zwaveCompany”:“Goap”,“zwaveInfo”:“3,4,5”,“zwaveVersion”:“5.0”,“categories”:[“lights”],“configured”:true,“dead”:false,“deadReason”:"",“deviceControlType”:2,“deviceIcon”:1023,“emailNotificationID”:0,“emailNotificationType”:0,“endPointId”:0,“energy”:8536.3,“isLight”:true,“log”:"",“logTemp”:"",“manufacturer”:"",“markAsDead”:true,“model”:"",“nodeId”:76,“parametersTemplate”:0,“power”:25.8,“productInfo”:“1,89,0,2,0,81,5,0”,“pushNotificationID”:0,“pushNotificationType”:0,“saveLogs”:true,“serialNumber”:"",“showEnergy”:true,“smsNotificationID”:0,“smsNotificationType”:0,“state”:true,“switchAllMode”:"",“useTemplate”:true,“userDescription”:"",“value”:true},“actions”:{“reconfigure”:0,“reset”:0,“toggle”:0,“turnOff”:0,“turnOn”:0},“created”:1591526183,“modified”:1591526183,“sortOrder”:107}
does not show up where
{“id”:779,“name”:“Licht Brüo Karin”,“roomID”:232,“view”:[{“assetsPath”:"/dynamic-plugins/com.fibaro.binarySwitch/assets",“jsPath”:"/dynamic-plugins/com.fibaro.binarySwitch",“name”:“com.fibaro.binarySwitch”,“translatesPath”:"/dynamic-plugins/com.fibaro.binarySwitch/i18n",“type”:“ts”}],“type”:“com.fibaro.binarySwitch”,“baseType”:“”,“enabled”:true,“visible”:true,“isPlugin”:false,“parentId”:419,“viewXml”:false,“configXml”:false,“interfaces”:[“energy”,“light”,“power”,“zwave”,“zwaveMultiChannelAssociation”,“zwaveSwitchAll”],“properties”:{“pollingTimeSec”:0,“zwaveCompany”:“Goap”,“zwaveInfo”:“3,4,5”,“zwaveVersion”:“5.0”,“categories”:[“lights”],“configured”:true,“dead”:false,“deadReason”:"",“deviceControlType”:2,“deviceIcon”:1023,“emailNotificationID”:0,“emailNotificationType”:0,“endPointId”:1,“energy”:4318.7,“isLight”:true,“log”:"",“logTemp”:"",“manufacturer”:"",“markAsDead”:true,“model”:"",“nodeId”:76,“parametersTemplate”:0,“power”:25.4,“productInfo”:“1,89,0,2,0,81,5,0”,“pushNotificationID”:0,“pushNotificationType”:0,“saveLogs”:true,“serialNumber”:"",“showEnergy”:true,“smsNotificationID”:0,“smsNotificationType”:0,“state”:true,“switchAllMode”:"",“useTemplate”:true,“userDescription”:"",“value”:true},“actions”:{“reconfigure”:0,“reset”:0,“toggle”:0,“turnOff”:0,“turnOn”:0},“created”:1591526183,“modified”:1591526183,“sortOrder”:108}]
is shown. This is a double switch (one switch with two lines). One is shown and one not.