Home Assistant Alarm integration

I’m trying to configure Home Remote to arm/disarm my Home Assistant connected alarm. The HA integration found the alarm, I added it as a device, and it brings up the list of arming/disarming options. However, when I choose one I get an error message at the bottom that quickly fades out - “int() object must be a string a bytes-like object or a number, not ‘NoneType’”. I assume this means I need to pass in a PIN but I can’t find any documentation on what property/variable needs to be set for the plugin to pick it up. I can deal with creating a keypad, etc. once I know how to correctly pass the arguments.

Telling me how to do it would be great, but showing me how to find it myself would be much better.


I don’t know that’s necessarily PIN related. According to the service description the PIN is optional. You shouldn’t need a PIN. I’m not certain what is triggering this error you are seeing. I’m assuming if it was a PIN related issue the service would return a PIN error.

I’m assuming it’s coming from Home Remote, not Home Assistant. I don’t see any kind of connection attempt from HR, although I may be missing it or it might not be logged.

Is there a way to enable more verbose logging in the HR Designer for the delivered plug-ins?

There is not. The error you are seeing is what’s returned from the HA service. The Home Remote just forwards that error.

Do the Home Assistant web interface & apps require you enter a PIN?

Yes, the web interface requires a PIN. I’d never tried it without one until you asked, and now I see that I get the same error in the HA web interface if I click one of the arming buttons without a PIN.

Any pointers on what needs to be done to pass a PIN from HR to HA? I’ll hard-code it to test and then implement a keypad tile once I can successfully arm/disarm.

Thanks for the help!

There currently isn’t any way to supply a PIN. This is something I can probably add to a future release.

Which HA alarm integration are you using? I’d check its configuration. It may provide a way for you to set a default PIN for it to use when one isn’t provided.

I’m using the Elk M1 integration. I’ll see if I can figure out if a default PIN is an option.