Honeywell Home not connecting

I am trying to add my T9 thermostat to devices in the designer and the login screen for Honeywell Home does not do anything when I click log in. If I click the the reset password I do get a email to reset. The log in button seem to do nothing

Thanks for looking in to this

Can you update your IE browser to the latest version?

I believe 11.508.19041.0 is the latest. At least that’s what’s installed on my Windows 10 PC.


I don’t norrmailly use IE, I generally use chrome. Is it using an IE Control to make the call to the honeywell home cloud in the designer? If that is the case I will do it later when I am home and see if it fixes it thanks

The embedded WebBrowser control the Designer uses is IE based I believe. On Windows 10 it could also be Edge based. So actually, update both browsers just to be safe. What OS are you running?

win10. I will take care of it in the morning and then I will try again, thanks

This is what the login screen looks like. The one my laptop works fine and looks like the right screen. Both browsers were up to date.

That looks quite a bit different than mine. You said your IE version is 11.508.19041.0?

Have you tried just using the Enter key? You may have to also use the Tab key to shift focus to the button. You should be able to login without even having to click the button.

If I save the hrp I am working on and send it to my work computer and add the device. Since I can set up the honeywell home integration on that computer. Then save and send it back to my home computer it should be linked then. Is my thinking correct?

Access tokens aren’t saved in the file so I don’t think that will work. Have you check to see which IE version you have installed? Did you try with the Enter key like I suggested in previous post?

Yes, Everything is up to date and I tried the enter key and tab to the button. Not sure why the page is not fully loading on my end

Can you open your registry & check the value of this key?

Computer\HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

“HomeRemote.Designer.exe” should have a value of 11001

The Designer tries to force WebBrowser control to use the latest version of IE by updating that registry key. Maybe for some reason that isn’t updating.

Actually that key is not even in the registry. I added it manually and rebooted still did not fix it. I tried to uninstall and reinstall but MS did not give me an option

Try adding the key to HKEY_LOCAL_MACHINE as well. I’m a little concerned that the key was not even in the registry.

This is what the screen looks like on my laptop and it logs in.

PS: and the registry keys were not installed on this device but it worked without them just fine. Really weird that the machine I use the most is the one not working right.

Still can’t get the honeywell home screen to load correctly in the designer. What is weird though is if I open the page properties for the HH login screen and copy and paste the target link in a regular chrome or edge window it loads the correct login page in the browser and asks if I want to allow and select the thermostat but since I am not in the designer but a browser window it goes to the home remote website with a 404. Is it possible I need to update some VS controls and if so what package should I download? Also I tried to open a new project and put the api link in a web browser control and i get the same non working login screen

About the only solution I have for you right now would be to reset the PC. I know that may not be ideal but it’s going to take some time for me to create an alternative way for you to authenticate this device.
Settings -> Update & Security -> Recovery -> Reset this PC

Then, the very 1st thing you do afer Windows finishes reinstalling, install The Home Remote & try adding Honeywell.

You know you are probably right I have been putting it off for awhile doing a format and reinstall of windows. Thanks I will do it soon and see if it works then

Maybe download the latest Windows updates too before the reset. I always like to have the latest Windows installer before initiating the reset. Version 2004 is the latest.