Readding device Netatmo give error ”Value cannot be null. Parameter: value”

Readfing device Netatmo give error ”Value cannot be null. Parameter: value”

Why is this?


Do you have any ideas on this?

What type of device is this? Is it online? Can you view live data from the device in the Netatmo app?

Netatmo is a device thatis built of a central device to which additional devices are added. The central device handle some measurements like temperature, humidity and noice level.

The additional devices have differenr purposes. We have an addon devide that meausure temperature. And another that measure wind. And a third addon device that measure rain fall.

The error comes when i try to add Netatmo a service to The Home Remote.

Our rain gauge device was added quite recently.

Do you think maybe it is the rain gauge that is not implemented correctly in Home Remote? Maybe Home Remote fail to handle the rain gauge and give the error i describe?

And yes, i can view all data with the netaymo-app

Rain gauge should be compatible. They do occasionally change their API around a bit. Maybe they made an update that the Home Remote app can’t handle. Do you mind sharing the device with so I can connect & troubleshoot?

I can confirm that the Rain gauge is working as normal in HR

Good day,

I also have the problem when I want to insert my Netatmo account!

I’m having exactly the same problem. All works fine in the Netatmo iOS, Android, and Web apps as well as the device is sending data fine to Hubitat.

I have two Netatmos in different homes, so I thought that might be it. I tried logging in with just the local device only ID, but same result.

I just sent and guest invitation.

Hi Steve, thanks for the invitation. I accepted & everything linked fine without any issues. Here’s screenshots of the app.

Thanks for the quick response! What you pulled together is just about what I’m trying to accomplish.

So I wonder if I’m doing something more fundamentally wrong then? I’m new to Home Remote, so I’m sure it could be something very basic.

  1. I Right Click on Devices to bring up the Integration list.
  2. Select Netatmo.
  3. Enter my login info, Login, and Accept.
  4. At which point I get the error message. image

Could there be a setting in the Designer that I’m not getting right? Linking to Hubitat worked great out of the box…

Thanks for your help!

What version of the Designer are you running? 4.5 is currently the latest.

Also, to do what I did in those screenshots, you don’t even need the Designer. Those are the default layouts that are built into the app. Simply link your account & that’s what you’ll see. There’s really nothing else involved. Can you try adding Netatmo to the Home Remote apps directly like I did & see what happens? Take the Designer out of the question. I wonder if they work or possibly give you a different error.

. Thanks for helping!

The Designer is at 4.5, so I think we’re good there.
I tried as you suggested without the designer using my Netatmo Administrator accounts. Received these screens:

It was pretty slow moving along and eventually hung on the last one and never cleared. So I went back to the Home Remote screen and Netatmo was there. I clicked on it and received the null parameter message again.

Cleared that and went to edit the Netatmo Device, which gave me this:

The email field was blank, which I suspect has been the Null Paramter all along. So I deleted the Device. Went to Netatmo and added myself as a Guest using a different email address. Repeated the Add Device in Home Remote using the Guest email. And it works.
There is an email in the Netatmo screen, it lets me select Netatmo devices and it lets me show details with live data.
So I went back to the Designer and did the same thing. It too added the Device with no errors when I used the Guest email.
So, maybe something in Netatmo security about linking to an Administrators account?

Anyway, thanks again for the help! Now I need to get myself up the Home Remote learning curve to create my Dashboard…

Unfortunately, it doesn’t work for me with a guest email either!

Does your admin account have access to a device that guest doesn’t? Is there anything that you haven’t shared with the guest account?


I made a mistake and shared my whole account, not just my weather station. Now I have only shared my station and it works! Thanks

I don’t recall ever setting anything around security other than passwords.

So I poked around in Netatmo and didn’t see any security or privilege setting other than Home (Admin) and Guest Users. I went to their help site (Netatmo Helpcenter) and found this which explains the difference between the user types.

For what it’s worth, I have two Netatmo weather stations and no other Netatmo products. I have a master Home User that sees both stations and then a local Home User for each station that sees only the station in that home. Then I have three Guest Users, one that looks at data in one house, the one I shared with you Bill that only sees one house, and the one I added for myself to use in Home Remote that actually worked that sees both weather stations.

I’m out of ideas at this point! Best I can tell, I am completely generic on the Netatmo side.