Simple IP camera connection issues

Running into an unexpected problem with my IP cameras ( 4 X D-link DCS02330L).
The IP user interface is simply http://user:pw@IP:80/video/mjpg.cgi.
It works perfectly in my browser, VLC, and my QNAP NAS. I’m just getting started with the home remote and setup some auto groups, including the IP cameras. Each camera is configured as follows:

image

They are loaded in the camera group, and each is using the default IPCameraTile.xaml and IPCameraDetails.xaml settings.

When I load the page (both in the simulator and on 2 different ipads), I see a brief flicker of the camera’s image, and then nothing- no further image. This is the same result whether I view multiple or single cameras per page, both as thumbnail and full screen. Same error has persisted over a few days, devices and cameras have been reset. Everything else in the remote works fine, and the feeds are still accessible to other methods.

Anything I’m overlooking, or suggestions to offer? Thanks.

Any chance you can set up port forwarding on 1 of these streams so I can go online with it & troubleshoot?

If you rather not, try the snapshot URL. I believe it is “image/jpeg.cgi” for those cameras. Or you can wait a week or 2 for the next release. I’m working on a new ONVIF integration & some significant updates to RTSP streaming on all platforms.

I suppose I could if you think it would really be helpful. Has this been a common issue?
The cameras support an RTSP stream, but I’ve never used it. Do you expect the new release will address some bugs with the mjpg streaming as well? I suppose a new platform is a new platform, so may be promising.

Not that I’m aware of. MJPG streaming is working fine for my cameras. I’m not currently working on any HTTP MJPG changes but if I find a bug when I connect to your camera I’ll definitely include a fix for that as well.

Hmm, oddly another camera reboot seems to have corrected the issue. Good old technology, :thinking:

Why don’t I run with it for a bit and see if it becomes a recurrent issue and I’ll let you know. Thanks for the offers to debug! And I’m loving the program so far!

1 Like

So 24 hours later the same connectivity problem has returned. Fixed by a simple camera reboot. Only affects the Home Remote connection, no others, so I’m not sure why that would be. If it makes a difference, I’m not currently running an always on panel, just booting one up periodically as I’m still developing what I’d like it to look like.

My offer from earlier still stands.

Here’s a website that shows how to set up port forwarding in case you’ve never done that before.