SOLVED - Cannot start HomeRemote designer

After a failed attempt to copy and rename a page, I can no longer start HomeRemote Designer.
I get a message that I have to install NET which I did (version x64 and also tested x86) but I still get the same message when I try to start HR.
I have also uninstalled HR, restarted the computer and installed HR again, but the same dialog box comes up again.
How can I solve this problem?


Now it works again!
There were three different NET variants to choose from Console apps, Desktop apps and Server apps.
I had installed Console apps, but the right one would be Desktop apps.

1 Like

I have the same issue, downloading the Desktop apps one now.


HI i had the same problem, installed desktop NET and I’m now able to run HR but it Crashes when you start Debug. does anyone have the same problem?

Does it crash for all projects?

What happens if you create a new project & don’t add anything to it? Does that also crash when you start the simulator?

The app simulator (Play / Start button) seems to be working OK for me in my project.

Hello Bill
I’ve just tested that and it didn’t crash, so on my project I’ve removed the mediaElement i use for CCTV
and it didn’t crash
use to work fine before the desktop NET thing

Can you send me a project so I can try to replicate the issue? Please remove any sensitive information that you do not wish to share with me.

bill just sent it to

It’s not crashing for me. It looks like you removed your MediaElement though. Also you sent me your entire project. If it’s the MediaElement that is crashing, then couldn’t you create a simpler example? If that’s the issue you should be able to replicate that with just 1 page. I’d really appreciate that.

hi bill not sure what’s going on with this, the media element is still on that project and works on the ipad, just not on the HR debug ive just set up a new project, ill send it to you to see.
i added the camera in the devices and its found it and all info is correct but i cant add it to the media element as the source binding cant see it
thanks tony

It’s because I wasn’t connected to your camera. There is a bug with the decoding of RTSP frames. I connected to one of my RTSP cameras & it is indeed crashing. I’m looking into this.

I just uploaded a fix. Download the update.

just tested with new update work fine now


For Designer version you are going to need the latest .NET Desktop Runtime 6.0. You can download it here: