Strange Issue with Tile Device (@switch) not turning off


Im not sure yet if this is device related, but I cannot get the dimmertile template to switch off my switch device linked to the @device property.

Ive made a group for my vera lights and created a device browser and all displays correctly and when i click the tile it switches on and changes colour, but it wont switch back off when i press again. Im trying on an ipad and in the simulator it works as it should - both on and off.

Ive bound a text to the device state and it changes from off to on correctly after the press on the device, ive also tried ending the app and reloading with the light on and the app starts showing the light in the correct on state but still cant switch off.

Im not sure if anyone in the group can test the file with my setup to double check? Ive also tried adding a transparent button to handle the switch process rather than the tile itself but the issue remains.

Attachment removed.


I just tried your “Cabin Lamp” tile & that worked fine for me. I turned it both on & off a few times. You may want to consider removing your credentials from that project once resolved, or remove them now even.

Shoot sorry - I always forget to remove my credentials.

Just to update, I woke up this morning and the ipad started to install an update to THR ( i manually “updated” in the store last night) and its now working, I can only assume the update didnt install yesterday.

Thanks again.