Unusual Slider Behaviour

My Home Remote setup recently developed an issue with slider behaviour, which has my baffled! I did recently update both the iOS app and the Home Remote Designer. I believe something has broken somewhere but I am struggling to diagnose were the issue is coming from and fix it.

I have dimmable lights controlled via a Z-Wave Vera. Scenes still operate normally from Home Remote. All other elements of the Z-wave system appear to be fine. I have tried the usual!

On the remote layout, down one side I have one large slider, on the other side I have buttons which effectively choose what light you are going to control with the large slider. In normal operation you select a light using the buttons and the slider will jump to the Z-wave value of the corresponding light. This still preforms as expected. However when you try and change the level on the slider, the slider appears to move, but the light does not respond.

To change what device the slider is bound to, the selecting buttons simply use a ‘property action’ targeted at the slider ‘Value’. An example of the value is ‘{Binding Zone_06_Snug.Level}’ Each button has a different value, corresponding to the z-wave devices. The slider appears to see these changes as the position of the slider jump about to the correct z-wave values, but no longer actually changes the value of the actual z-wave device.

I am slightly confused what has happened, it used to work perfectly!

I have tried inserting a new slider, but that also has the same issue. I have also put in a slider on another page fixed to one device (ie without having any ‘property actions’ changing the binging). This slider will work as expected, but if I retarget the ‘property action’ to the new slider, when the value of the slider changes by the ‘property action’ the fader will no longer control any z-wave dimmers.


I will keep trying things, and report back any positive progress! But if anyone else has experienced similar, perhaps they can point me in the correct direction for fixing this.


This will be fixed in the next release 3.18.0. I think this got broken in the 3.17.0 update. When Value Bindings were added to the DataAction class they were set up to default to OneTime mode. There’s some code-sharing between the DataAction & PropertyAction classes so that same OneTime Binding code got applied to PropertyActions as well. PropertyActions used to default to TwoWay mode. I’ll go ahead & revert those back to being TwoWay again.

I do think there will be cases when someone will like to use OneTime instead. Support for the BindingMode parameter should probably be added to software at some point. This could be a future enhancement I suppose.

Attached is the project I created to confirm the issue.
Unusual_Slider_Behavior.hrp (7.9 KB)

I can confirm the issue has been fixed. Just updated iPad to v3.18.0 and everything is working again as it should.

Bill, Thanks for fixing the issue and fixing it fast!