WebOS TV not returning correct .Switch response


I am having an issue with the LG WebOS Device… its not returning the @Device.Switch status as “On” when the TV is on… it returns “Off” when the TV is off, but “Unknown” when the TV is On.

This means that when I set my Setters to look for the “Unknown” status, rather than the “On” status, the TVs appear as ON for a brief time until the poll times out.

Does this make sense?


Try cycling power on your router & WiFi network. The app uses SSDP Alive & ByeBye to help monitor the state of the TV. Your equipment could be in a state to where it’s not forwarding those messages. Restarting your router can sometimes fix those kinds of issues. The TV connection is quite a bit different than any other. When the TV is off, it does not respond to API requests. It’s not like typical home automation components that are always on & listening. Even surround sound receivers will usually handle network requests when the receiver is in off/standby mode. TVs aren’t like that.

Thanks Bill. Yes I already figured out that you can’t send these guys a Switch On command because they don’t have the receiver equivalent of network sleep so I got round that by poking my Vera to send an IR Power On from my Keene Ip2IR boxes.


That’s not true nor is it what I was trying to say. I was describing the problems that can arise with tracking the status. Switch On commands will work so long as you have the “Mobile TV On” setting enabled. When that is enabled it will power on when it receives a WOL command.


Oooh that IS good to know. Thanks Bill. That should make my probs go away.

Thank you.

Found the network wake setting on two of my three LGs. Just need to get the daughter off the Wii to get to the third. Thanks Bill.

1 Like