Where to copy hrp file

Hi, I’ve created a custom remote and I’m using nextcloud (like a private dropbox) to sync it from my computer to my tablets. I then open NextCloud on the tablets and launch THR by opening the hrp file. I have a few related questions…

  1. I noticed that since I launched using a custom hrp file, I can no longer click The Home Remote icon to launch the app - when I do, it just spins forever. Is that expected or is there a problem with my setup?

  2. I’d like to copy the file out of my NextCloud folder to some local storage area on the tablet so when others use it they do not need to be logged into my NextCloud account. Is there a preferred location to copy it to?

  3. Is there a way I can copy the hrp somewhere local AND configure it so that clicking The Home Remote app will open the app and load the custom hrp file?

That shouldn’t be. You only need to publish a file once. After you open the file from NextCloud, its contents are extracted to the app directory. When the app opens again from the launcher it should use the last file you published.

Maybe there’s something in your project file that is causing the normal application launch to lock up. Try another project file to see if it produces the same results. Here’s a simple one you can test.
TestProject1.hrp (5.6 KB)

Using the test file, when I close out of HRP and then re-launch using the icon, it reopens the test project as you suspected. However, using my project file it just spins - I just tried again and it’s been spinning for over a minute now. I have a large project file (a little over 5MB) but when I launch from clicking on the hrp file it loads in about 5 seconds.

Any suggestions what I could look for in the project file that might be causing this?

It’s very strange how it’s able to open the project when 1st published but not afterwards. Can you maybe create a copy of it & remove all sensitive information, then email me a copy?

Send it to support@thehomeremote.com

Thanks!! - Just sent

Got it. The project is working fine on my Galaxy S9. I’ll dive into it a little bit more on some of my other Android devices have issues with it.

Just to confirm, have you tested this modified file on your Android devices? Does the loading issue still exist with this file?

I just tried it and yes, it’s behaving the same way, just spins when I try to launch using the app icon. The way I’m testing is launch once using the sync’d file link, then swipe the app off screen to close it, then try to launch using the app icon. If it matters, I’m running on Lenovo M10 FHD Plus tablets.

Here’s something interesting…

Tried doing this from my Android phone (OnePlus) and found that when I launch from the nextcloud file it loads up in about 3 seconds. When I use the HR icon it does load, but consistently takes around 25-30 seconds.

Decided to try again on the Lenovo tablet and time it so my patience (or lack of) wasn’t skewing how long I was waiting. The NextCloud file link takes about 5 seconds to load up and clicking the HR icon DOES load - but I’ve tried twice now and it took 2 minutes and 20 seconds each time.

It’s the FTP settings in your project. It’s trying to download the project from @Jdamore’s FTP server which isn’t on your network. My guess is that you started from his example but forgot to clear those settings. I’m not sure why it’s taking so long to timeout. It’s supposed to timeout after 10 seconds but it doesn’t appear to be doing that on some devices. Either way, clear those FTP settings because I’m guessing those aren’t settings that you are actually using for your environment.

Wow, thank you for finding that. Once again your fix pointed me to an area in THR I had never even noticed before, so I have something new to check out now. When you said FTP settings, I had absolutely no idea what you were talking about - I unzipped the hrp and did a search to help me find where that might be :slight_smile:

After removing that it works exactly the way I had initially expected it to. Thanks!!

Oops! Sorry guys! I’ll remember to clear that out before I post examples.