Can't Connect to Homeseer HS4 through MyHS

I recently upgraded my Homeseer system from HS3 to HS4. Before the upgrade I had no problems connecting to my system remotely through MyHS but since the upgrade I am only able to access it when I’m on my local network. I have added a local user within Homeseer with the same username/password as my MyHS account and the Homeseer Mobile app works fine. If I try to update/save the Homeseer device settings within the Home Remote app while not connected to my local network I get a “request timed out” error after about a minute. If I delete the Homeseer device from the app and re-add it while not on my local network I get a “Timeout from host, source IP: TimeMS: 15013” error. Is there something I am missing?

For HS4 you need to create a local account with the same username/password as the MyHS account.

I have seen you mention that a few times in other threads. As I mentioned I did already make a local account with the same username/password as my MyHS account. After I did that the Homeseer Mobile app began working again but the HR app still refuses to connect remotely. I have also tried uninstalling and reinstalling the HR app (i’m on iOS) but that didn’t change anything.

The Home Remote follows the same exact procedure as outlined by HomeSeer in this documentation.

Here’s a short summary. It sends the “getsystems” request & uses the response to determine how to connect:

When detect_wan_ip and the hswanip are the same, then Home Remote will use the hslocalip to connect to the HS system.

When detect_wan_ip & hswanip are not the same, then the Home Remote will use the tunnelip.

Feel free to send the “getsystems” request yourself to analyze why it’s not working.

Or if you’d like, I myself would be happy to test your project myself & troubleshoot if want to email me it.

I’m not sure why but it appears to be working now. I did the getsystems request from safari on my phone (using cellular data) and it returned a valid response. I then tried to add the Homeseer system to the HR app and it connected no problem. Not sure if the getsystems request somehow fixed something on the Homeseer end but I’m happy it’s working now. Thanks for your help!

1 Like

Thanks for this getsystem explanation, I now understand how you connect to homeseer via MYHS, let me explain my problem and see if you might have a solution for me.

I have my main HS4 system connected to my main network router on network 192.168.1.X. On this 192.168.1.X network, I have a second router doing it’s own DHCP on 192.168.8.X. where I have a secondary Hs4 system connected to.

What I am trying to achieve is build an hrp that could access both systems either I am on LAN or WAN.

I understand that with this setup I can probably access both system if I am on a WAN BUT when I am developing my HRP on my laptop connected to 192.168.1.X I can’t access the second system

Would you have a idea on how I can get that to work ?


I think what you are asking for no user here will support…You are asking for web services (cloud). The client (Home Remote) can only point to one server at a given time, when using the designer and when launching.

Else, what I think you are asking for is similar to what HomeSeer cloud services uses to connect to your servers using MyHS relaying your servers to you. Unless you are asking the dev of Home Remote to add extra server interfaces to the HR client app to work like the HStouch app … There may be some ground to cover…but who am I to argue over that though… Yes, with the HSTouch app you have the option to add at least four servers but…
Right there!..The ball is in your court :thinking:

I saw something else while looking your post again…

  • On the Explorer Pane right click and add another HomeSeer device

  • Test to see if you can connect


The rest is on your side of things. If that works then you can design your project using Page Browser and may be Scenes…? So when you press a button it gives you access to the other server. Well…I would like see that but I don’t have two servers to test.
You also have to get one of these : USB Ethernet (LAN) Network Adapter Compatible with Laptop in order to be able to connect to the second LAN

Although you may be able to connect while using the Laptop, the hurdle you may come across is auto switching between the two networks ( WiFi). But unless you put in a suggestion for a Tasker Plugin for Home Remote, there is little this app : [] can help you to auto switch the SSIDs (You may need to use its Widget…)