Download page not working?

Hi All. New to the Home Remote. I was trying to download the installer but the link doesn’t seem to do anything:

on this page:

Any help would be greatly appreciated.


Click “Get the app” on that page & it will launch the installer. You need a PC running Windows 10 or later for the link to work.

Hi Bill. I have a Mac, but I’m running Windows in Parallels. Any way to make the installer work with Parallels? Do I need perhaps lanch Chrome from within Parallels for the link to work?


It should work fine in a virtual. So long as it is Windows 10 it should work. Is it Windows 10?

How else would you launch Chrome?

I’m a little confused. Isn’t that the only way to launch Chrome in your virtual machine.

Sorry, yes I solved it. I was trying to download the installer via chrome on my Mac, but I need to launch chrome from within my Windows/Parallel machine for the installer to work. Was able to install it successfully.


1 Like

Yes it’s Windows 10 FYI. :slight_smile:

1 Like

I have a different problem, I intalled it but I can’t run desiner. It keeps me asking to download .NET i did, still not running. Using Windows 11

There are a few different variants of the .NET 5 runtime. Make sure you install the “Desktop” version.

Working now, Thanks Bill

1 Like