HEOS drive not working

I recently connected my HEOS drive hs2 to the app on my phone. It refuses to connect and is saying “the operation has timed out” when activating any command…volume, power, ect…

You usually see that when the IP address isn’t reachable. Are you sure your phone is connected to your local WiFi network & not cellular? Have you tried uninstalling & reinstalling the Home Remote app?

Yes I’m on wifi with a strong connection in my house. I have also tried to install as a new device via the home remote designer on my laptop over ethernwt and I get the same errors.

Test in the actual apps 1st. Don’t try in the Designer until you’ve got it working in those. Please uninstall & reinstall the app as I suggested. Also, try a few different phones & tablets to see if you can get any of those working.

Is the official HEOS app currently working on those devices?

Yes the HEOS app is working flawlessly on the same device. I rebooted my router and reinstalled the app. It is now pulling the data intermittently and show the album cover for a minute… once you click on any of the controls it continues to say “This operation has timed out”. The album cover will then disappear by itself and re-appear once I click on a control but none of the controls work. The HEOS is brand new out of the box and required that I install updates before attaching a audio source in the HEOS app. Could there be an update that is causing this problem.

Forgot to mention that these intermittent results only work if I add Denon as a device. When I add HEOS as a device I get no results.

I don’t know. I have never tested the HEOS drive. I’ve only got my Denon AVR so that’s what I am testing. Denon AVRs & standard HEOS speakers really only have 1 built-in HEOS player instance. This HEOS drive HS2 unit is a bit different because it is 1 unit but it has 4 different HEOS players. Could be related to that.

It’s also possible that it is maybe related to the source you are playing. Try different music sources. If you are listening to Spotify, try Pandora, etc.

Here are some screen shots I believe the issue is that Denon Drive assigns 4 different IP addresses to each zone. If I can associate a ip address as a speaker then this may solve the problem.

The 1st screenshot looks as I suspect. Your other ones don’t really make sense unless you have more Denon devices. Delete those other 2 HEOS sources.

The Router assigns - 28

How can I associate an IP address to a specific speaker. I believe that’s where the IP conflict is

Sorry its -27

Your screenshot shows 3 HEOS icons, that’s bad!

I don’t know how the app let you do that because it shouldn’t have.

You should never have more than 1 HEOS source. That is your issue. You only need 1. With the way the HEOS API works, it only needs 1 IP address.

Keep your device & delete the other 2. Then click the sync/refresh button underneath & it should pull in your other devices.


This last 1 in the Designer shows 4 HEOS sources, that’s even worse!

ONE! You should only ever see 1 HEOS icon in a project. I don’t know how the software let you do this but it shouldn’t have.

I also asked for you to uninstall & reinstall the app earlier so we could isolate this HEOS issue & it doesn’t appear that you did that. You’ve all of this extra stuff Ewelink, IP Cameras, 3 additionals HEOS sources. Just add the 1 Heos device. That’s it.

Here’s page 6 in their API docs. Read the part that I’ve highlighted.

You’ve got 4 connections in your project. That is not good.

Does what I’m saying make sense?

Please make the changes I’ve suggested & report back with whether it fixes your issue.