Home assistant connection failed when HTTPS

Hi, I was using Home Assistant without HTTPS, it was workiing fine. But few weeks ago, I did switch to HTTPS, since this date, everything is working fine on Windows 10, but on android, it is impossible t connect :frowning:

Capture d’écran 2021-10-03 144744

I did the correct thing in the Deisgner because I have the same configuration in Windows version, and in the windows 10 app + In the designer it is working. As you can see, when I upload the configuration in the android App, the internal adress is forcing to http…INTERN ADRESS

I’m having the same issue…

Have you updated the “internal_url” in Home Assistant?

The Home Remote reads those from Home Assistant. Make sure those values are correct.

Hummm, Yep ! I didn’t update the internal Url, I juste did. but it is not working…

same message unable to connect to the remote server…

When i use this same configuration in the windows 10 app, it is working…

What version of Android OS are you using?

Does the Settings screen still show the 192.168.X.X address?

Try publishing your latest project to the Android device again. It could be that your previous attempt was unsuccessful.

i’m using android 11, i tried to publish several time, even by erasing data

the setting screnne don’t show 192.168.1.2 anymore

same thing in android 10 on a other phone

Is that URL accessible in the Chrome browser on your Android phone?

“Unable to connect to the remote server” is basically saying that the URL can’t be reached. If the Home Remote can’t access it then it’s very unlikely Chrome will be able to on that same device.

yes, i just tried, it is working on chrome, and i try it with a copy paste frome home remote config

Hummm

I’ve just uninstalled The Home remote then I installed it again… Then new project and searching from zero…

It was Working, The app find it… But when i did log :

1 Like

If you are still having issues you can read through this discussion as it may provide some tips on how to get it working.

I’ll give up for tonight… However, thank you for your help

I’m having the same issue myself.

I even tried to run the configuration from scratch, without a success.
When I have the phone on the same local network with HASS server, and I go to “Add a device” menu, select Home Assistant, it seems it is found on the network, but only white screen comes up (instead of HASS login window).
When I do that on different network, there is a window with a single URL to be set (no external or internal), but when I put https:// address, I immediately got “Failed to connect to” error.
All other similar apps connecting to my HASS server using https are behaving fine.

In the past I had the similar behaviour of other apps as well (white screen instead of login), but it was due to incorrect certificates configuration on HASS, but now they’re corrected.

EDIT: I think I started to understand the issue.
When I’m on a local network, same as HASS server, and try to add it in Home Remote, it is detected automatically with https://local-ip-address, but the certificate is issues to public-dns-name, hence a mismatch, and the white screen.
I believe Home Remote should be able to either override this certificate mismatch during connection, or accept https://public-dns-name.

@Petucky2 Read through the discussion here. There are other users that have gotten HTTPS working. Maybe @dk38 can provide some more details if anything is unclear.

I really dont understand why it is working on windows… in the App (windows 10) and the designer…
It is even working on Windows 11 :slight_smile:
We are so close…

Does it work on your Android phone when you are away from home? What if you disable WiFi & force the use of cellular data? Does it work then?

for me, it doesn’t. I enter my public https://dnsname. The same works ok on windows app (both on the same network and the different).

I was also able to run reverse proxy, I can easily acess HA from my computer on the same network using http protocol with different port, but when I put it in the URL field of Android app, I got failed to connect error.

Do one of you guys @Nicolas or @Petucky2 mind letting me connect to your HA instance so I can troubleshoot? If your OK with that private message or email me connection info.