Integration request: Home Assistant support

Thanks Bill for the Reset file that was needed since I have a complete custom project.
So after starting this file, I tried to add the Home Assistant device on my iPad and this fully crashes Home Remote and returns to the iOs pages. To make sure this is not due to ay other reason, I added my Denon amplifier which worked fine. The App version on the iPad is 3.19.1 which I believe is the latest.
I also tried on my Android tablet which did not allow either to load assistant but at least it did generate an error saying that the page could not be loaded with http://x.x.x.x:8123/auth/Authorize?.… with the following reason: net::ERR_EMPTY_RESPONSE. This is similar to what I get when running from a browser since it requires an https call. I have activated secured access since I want to access Home Assistant from outside with a dns service.

Are you using a self-signed or untrusted certificate?

Those will probably give you issues. Most web browsers will even complain if you try to access a site using a self-signed certificate. Safari complains on my iPad & so does Chrome on my Galaxy S9.

Right, I must be using self-signed certificate since I need to go through several steps to allow connection. Do you know if there are different way to generate certificates?
And would this resolve the link with Home Remote?

There are no doubt different ways to do this, but I ended up buying a cheap domain ($8/year) and using LetsEncrypt to generate free certificates for that domain. I was having increasing issues with self signed certs not being accepted. I considered $8/year a cheap way to fix the question of self signed certificates.

1 Like

@amingle Excellent suggestion!

@dk38 Your other option would be to use Nabu Casa.

This might help if you choose to use Let’s Encrypt.

Thanks to both of you. For the moment this is still somewhat complicated for me.
I will try to give it a trial and see what I will be able to come up.
But just for my curiosity, wouldn’t it be just easier to call Home Assistant from the DDNS service I use, ie, which works from any platform I used for the moment?

That doesn’t matter. It’s still going to generate errors if you aren’t using a trusted certificate. If you’ve already got a domain name, then all you have to do next is set up Let’s Encrypt. Those tutorials should walk you through how to do that.

Are you using HTTPS for both internal_url & external_url?

The Home Remote uses both URLs. I think in most cases, systems use standard HTTP for internal/local access. If you are trying to link Home Assistant on your local network, Home Remote should be using your internal_url. It almost sounds like you’ve got HTTPS enabled on your internal_url.

So I made a trial with a new ddns server on my Synology NAS. I was able to generate a trusted certificate from Let’s Encrypt and set the right files in Home Assistant. Now when I try to access Home Assistant from the https call I don’t get anymore the nasty messages from the browser, which makes me think that I have now a trusted certificate. When I now try to add Home Assistant from the Android tablet I continue to get the error net::ERR_EMPTY_RESPONSE
Same error from the browsers, when I try to access HA from http://x.x.x.x:8123.
I believe that I have set up HA to use https from external and http from internal with the following instruction in customize.yaml:
internal_url: http://x.x.x.x:8123
but calling http://x.x.x.x:8123 will fail with no response, https://x.x.x.x:8123 gives me a nasty message saying that the certificate is linked to and not x.x.x.x:8123, which makes sense. So for some reason HA does not respond to the internal call.
Any idea?

I don’t think you can have both HTTP & HTTPS on the same port. I’m not sure how that would work. So I kind of expect you’ll see “no response”. I also expect you’ll see errors when trying to connect using https://x.x.x.x:8123 because the Let’s Encrypt cert requires a domain name. I think you need to somehow set up 2 unique ports for both HTTP & HTTPS but I’m not sure how to do that.

Take a look through this discussion. I believe this user is experiencing the same issue you are.

I finally managed to get both internal and external calls to be working (it even seems to have improved the overall performance of Home Assistant). I used the NGINX app but only following the instruction would not work. Following the instructions from this site allowed a proper functioning (I am giving this in case others have troubles). I am now playing a little with it and it is just amazing the power of getting both applications to work together!
Now I ran into a little issue you may be helpful. I have all my radiators equipped with Z-Wave thermostats. I can pretty well communicate with each of them. The issue is that when I increment the ThermostatHeatingSetpoint to a value that is not an integer (ie 20.5) I get the following error: "expected float for dictionary value @ data[‘temperature’] and the value is not set in the thermostat. Any integer value works fine. If I do the same from Home Assistant it works fine. So I tried from the straight SettingsReset example you sent using the built in thermostat template and the same happens. I guess this must be linked to some interface with Home Assistant.

I just fixed this on my dev machine. It’ll be part of the 4.1.4 release which should be out in a few days.

1 Like

Hey @bill wondering if you’re still considering implementing this?

Refresh my memory. What are you referring to?

The thermostat setpoint fixes should have been in the 4.1.4 release. That is live in all of the app stores.

I did quote you but it’s a bit strange how this forum handles quotes.

I meant about your reply here:

Yeah, nested groups aren’t currently going to work. This can probably be added to a future release though.

Yes. That is something I still have to work on yet.

Cool ty.

Not trying to rush you or anything but do you have an ETA? Just trying to decide whether to bite the bullet and build the whole thing manually one by one or keep waiting for nested groups to work which in turn would mean the whole app would be dynamic and any device I may add in the future would automagically appear in the right place based on groups

I don’t think I’ll have time to include it in the next release. If I had to guess, I’d say sometime May.

OK thanks for letting me know.
Think I’ll may have to go the manual route then, was really trying to avoid it :frowning: