HTTP commands with deprecated HttpClient (not plugin)


I’ve just setup Node-Red to communicate with my ChromeCast video device for playback transport controls, PLAY / PAUSE / STOP etc using the node/node-red-contrib-castv2

I have setup some HTTP commands in node red it can accept to then control the ChromeCast. - Sends the Play command. - Sends the Pause command.

These work instantly in Chrome browser when testing them and playback pauses and plays right away.

I then setup a HTTP client in Home Remote to connect to the Node Red instance running on my Pi and added some buttons on a MediaControllerDetails.xaml template.

The buttons work kind of.

The first time I say press the Pause button it works as expected and the playback on the ChromeCast is paused.

If I then press the play button nothing happens for quite some time, it then eventually works and playback starts again on the ChromeCast.

Seems subsequent button presses are really slow. If I don’t press a play or pause button for some time and wait, if I then press one it usually works quickly as expected.

I probably have my HTTP client in Home Remote setup incorrectly.



In the Headers I have nothing in there.
In the StatusRequest the method is just GET


These are the two commands:



I’ve tried lowering the “RefreshRate” but made no difference.

Any ideas what I am doing wrong ?


I haven’t announced it yet but did you see Google Cast was added in the 3.14.0 release yesterday?

Please use that instead. I made updates to the MediaPlayerTile.xaml & MediaPlayerDetails.xaml files for this release. I recommend creating a new project & copying those 2 files into your existing.

Also, the HttpClient device has been deprecated. You should be using a Plugin to send HTTP requests.

1 Like

No I didn’t see that you have added support for Google Cast.

The only reason I have been playing around with the node-red-contrib-castv2 today, is because my Text to speech announcements from Vera to the Google Home speakers stopped working, as the old node-red-contrib-cast one I was using is now broken.

I fixed my TTS announcements OK, but noticed this new CastV2 one also did playback transport controls.

However as you say I’ll have a look at what you have setup instead.

So what can your new “Google Cast” integration do ?

And I keep forgetting about that…


Supports playback, metadata feedback like artist name, artwork, etc. You can even browse DLNA media servers like Plex to send your music & movies to it. Try it & see for yourself!

OK thanks I’ll take a look at it.

If I can have a screen where I can see what’s currently playing on a ChromeCast video / audio device and have basic playback control buttons that certainly would be cool.

I dont have one of the new Google TV Chromecast devices yet, but we have plenty of the prior Chromecast Video HDMI and Chromecast Audio 3.5mm jack ones around the house.

Yes. That is supported…

All Chromecast devices should be supported. All of my testing was done with my Nexus Player & Onkyo AVR with Chromecast built-in. I ordered a Nest Mini the other day & those should work too.

1 Like

Sounds great, we have a mixture of Home Minis and the bigger Home speakers in each room.

I’ve updated the Designer on my Windows 10 laptop.

If I try to add a “Google Cast” device I am seeing this:


I can ping all my Cast devices OK from the laptop.

However Cast discovery uses mDNS so not sure of any Windows requirements.

If I hit the Cast button in the Chrome browser on the laptop it appears to list all my Cast devices OK.

Reset the apps & see if they are able to find them. Load the attached SettingsReset.hrp file & try adding Google Cast & see if it works.
SettingsReset.hrp (1.3 KB)

There are sometimes discovery issues on PCs due to firewall & Network Discovery settings. Try in the apps, those issues do not exist there.

Opening the SettingsReset.hrp in a new Home Remote Designer session and then attempting to add a new “Google Cast” device it works and has added them:

EDIT: Some are missing, I don’t see my Lounge ChromeCast video


But in my existing live project I get the “Failed to find any new devices”.

Not sure why ?

Can I copy them from that new project in to my existing project ?

Yes. You can copy them into your existing project.

There’s no reason you shouldn’t have been able to add them directly into your existing. How many times did you try? Did you try closing & reopening the program?

Four times now. Let me close the designer and try again.

Also in the other new project, it did not discover my Lounge ChromeCast video that one was missing.

OK closed the Designer opened again and loaded my live project this time it has worked and detected most devices.

Strangely the Lounge ChromeCast video device that was missing is now present.

But the Lounge Speaker (Google Home Mini) the other blank project detected is now missing from the live project.

Right clicked it and Synced Devices, now the missing Lounge Speaker has appeared OK.

So think I’m good now.

I’m going to have to merge some Harmony Activity buttons for the ChromeCast’s in to the new MediaPlayerTile.xaml & MediaPlayerDetails.xaml template files, for the “Google Cast” device support.

Like the power button, I need to change that to turn on / off the correct Harmony activity that starts the ChromeCast activity etc. Also change some volume buttons / slider for the AVR amps rather than adjusting the volume of the ChromeCast device itself directly.

Likewise for the mute button.

But should be able to figure that out.

Anyway its connected and working:

So what does the “Media Servers” button do ?

What does the existing power button do on this page ?

You can’t turn off a ChromeCast device can you…

The power button closes the current casting application. It’s equivalent to the “Stop Casting” button in Google Home.

OK maybe I can add a stop button for that instead.

And as I said, change the power button to start / stop the Harmony activity that sets everything to the right AV inputs to display the ChromeCast on the TV screen.

And the Media Servers button ?

Doesn’t seem to do anything when I click it.

I have an Emby media server running DLNA on my WHS server.

It slowly found something:

I believe that is the old Windows Media Player 11 DLNA server running on the Windows Home Server.

Its not found the Emby Media Server DLNA server yet.

Which I’ve just checked in the Emby settings is enabled.

Are other UPnP / DLNA based apps able to browse Emby. Does BubbleUPnP find it?