"Hubitat unavailable" Error

Migrating from ST to HE (Rev C-7). Installed the Maker API, added the AppID, Access Token and IP address to the Home Report. When I hit Refresh, all I get is an alert dialog box on my IOS “Hubitat unavilable”. And there are no logs on HE.

Any ideas? TIA!

It doesn’t think your IP address is accessible for some reason. One of the network adapters may not be reporting that it is online. Try adding it on a different machine or tablet if you have one available.

The other thing you can do is enable cloud access. When you use an IP address there is a check to make sure 1 of your active network adapters is in the same subnet. If you enable cloud, it skips the subnet check & just looks to see if internet is available.

Thanks – That explains things a bit. My hubitat is in a IOT vlan and my phone was not. If I put the phone in the IOT VLAN, things work. Putting it back after discovering devices does not. While that explains things, if Home Remote cannot work across vlans, than this might not be a solution for me…

Cloud access does not seem to do much. Putting phone back in the non-IOT vlan and enabling cloud access does not seem to pull the device status either.

Any pointers on how to get this thing working across the vlans?

Yeah, these rules are in place so it can quickly switch between local & cloud connections. What I’ll do in the next release is just do a compare on the first byte of the address. If the 1st byte matches, it’ll attempt a local connection. I really don’t want to remove that check entirely. I think that should cover most scenarios.

This still wouldn’t fix your cloud connection issue though. That just checks the system’s reporting of internet availability. The OS is usually pretty good about determining this.

Did you set the “Hub Id” field?

For cloud to work, you need to specify the Hub Id. I wonder if that may be your issue.

This change has been added in the 3.9.2 release. Both the Designer & Android updates are available now.

Thanks Bill. I did set the Hub ID field but it was still a no go…
Thanks for the quick change in 3.9.2. I’ll need to go see when I can get that updated pushed down on IOS.

What error are you seeing when you try to add Hubitat with the IP address empty & cloud access checked?

Try rebooting your phone, try switching to cellular data. I understand why you are seeing the “Hubitat Unavailable” error for your local connection but I do not for the cloud connection. I would like to get that taken care of too.

With no IP provided, just cloud access with cloud ID checked, I get “unknown” status for all the devices. And changing their state makes no real changes to the device. Just the UI toggles.

I also did all this by disabling wifi, recycling cellular connection.

Please remove the Hubitat device entirely & readd it. That will show a more detailed error message which will describe why you are seeing “Unknown”.

I take that back, it should validate the connection when you click the save button. With IP field empty, it didn’t show you any error when you clicked the save button?

It looks to validate the connection, by throwing the dialog box “By not providing an IP address, you are disabling a location connection. Are you sure you don’t want to provide an IP address?”
I select Yes – then it returns to settings screen. But it does not pull in any new/refreshed devices and the status of devices is set to unknown.

Is the “Allow Access via Remote / Cloud” setting checked in the Hubitat portal? (not the one in Home Remote app)

Do the cloud URLs work on the Maker API setup page?

I wonder if there’s maybe a device you have that it cannot poll. Can you try removing all of your devices but 1 or 2 on the Home page? Just add a switch or light to the Home page. Close & reopen the app & see if it’s able to update those 1 or 2 devices.

Would you be open to creating a temporary Maker app that I can test? Let me look at it to see if I can figure out why it’s not working.

The initial validation in Home Remote only sends a request to the “modes” URL. If that succeeds then it assumes the connection is good. If it were my guess, the cloud URL for “Get Device Info” is locking up for 1 of your devices. I’d like to go through & test those with your setup.

I had an issue where a device (with a custom device driver was breaking MakerAPI. Do you have any errors in the MakerAPI log?

That was it. I did not turn on the Maker API Cloud access. Once I turned that on, without the IP Address, status of various things are promptly updated.

Now that that is solved, I am curious as to why the logs are getting pummeled with findDevice, listDevice and deviceItem calls. It is continuous stream. Turned off cloud access and switched to local access and I still get a continuous stream of listDevices. Isn’t that a bit excessive? It happens when the app is active.

Looking forward to seeing the new version come out on iOS that has the network check fix.

That might be a better question for the Hubitat developers. I’m not sure what findDevice, listDevice, & deviceItem are. When on a cloud connection, it periodically sends the “Get Device Info” request for each device. My guess is that call triggers those internal functions. When connected locally it’s able to listen to the event stream so it doesn’t have to send periodic polling calls. You probably won’t see those calls as much when you are connected locally.