Kodi Plugin (GridView)

Not sure if you are talking about the blue border around the selected item. This can be solved very easily by entering “no color” for the “SelectedItemBackground” property.


I did try it without a space as you suggested but still didn’t work.

Yes please can I have the json request to list all the internal genre names in the Kodi database.

I am using a central Mysql DB is that makes a difference?


EDIT: That got me thinking, I have queried the MYSQL database at the command line and looked at the contents of the genre table.

There are several different genres for SCI-FI listed in the genres table.

SCI-FI -> I can see this genre in Kodi there are like only 4 movies in there, I have changed their genre to be Science Fiction instead like all my other movies, this genre has now disappeared from Kodi after I refreshed those movie titles.

Science-Fiction -> I cannot see this genre in Kodi, must just be an old entry in the DB table. I tried setting the button to use Science-Fiction just as a test but no movies are listed in the project in HR.

Science Fiction -> I can see this genre in Kodi and all my SCI-FI films are in this genre. So this is the one I need to be using in HR.

SCI-FI & Fantasy -> I cannot see this genre in Kodi this must be an old entry in the DB table.

So when I set the button to Science Fiction with a space and then when I press the button at the bottom of the page I can see it pop up a message 808 is undefined.


OK this is interesting. I just tried making this button bring up the Animation genre instead.

So I edited the buttons label text and value to be: Animation

I was expecting this to work, however it does not and I see a popup message saying 489 is undefined. Could be 499 haven’t got glasses on.

If I set the buttons value back to Romance it works again and brings up the romance titles. So perhaps there is something somewhere else in this project hard coded for these genre buttons?

No - It was referring to when clicking on a season, for example “Season 2”, episode 2 is automatically selected in the refreshed gridview. Ive never been able to work out how to avoid it…


Sorry, ive not been monitoring the thread recently and not been actively working on the plugin. I like what you’ve done with it visually so feel free to keep posting your hrps as we can all share :slight_smile:
The genres should work based on what you have in your own setup although ive not used any with spaces (I dont think?). I will need to check the json command to see how this works, but as long as you have a genre sorted in your setup it should work.


Hi John

I tried to change that Romance button to Animation and then I tried Documentaries genres instead but that didn’t work either and I get an error is undefined.

So seems I cannot change that Romance button to any other genre not sure why ?

Also there is no GUI.SetFullscreen command in the Kodi script. So what I am assuming is the toggle fullscreen button doesn’t work.

In your hrp file that button is actually set to {Binding Movies.Genre} Thriller so its not correct.

The fast forward button also didn’t work its binding was also set to {Binding Movies.Genre} changing the binding to Commands.MediaCommand then makes that button work.


I tried this in curl at the command prompt which works, I will try to add this command to your Kodi script.

curl -X POST -H "content-type:application/json" http://user:pass@ -d {\"jsonrpc\":\"2.0\",\"method\":\"GUI.SetFullscreen\",\"params\":{\"fullscreen\":\"toggle\"},\"id\":1}"

Its working now that FullScreen button.

In the Kodi script on line 32 I added “Fullscreen” to the end.


And on line 324 I added the Full screen command:



I created a smaller portrait version today for my phone.

When I have finished I will share the hrp files.


OK here is the hrp file for the Portrait Phone project.

It supports up to three Kodi HTPCs.

I am still having big problems with these genre buttons however.

These are the ones that are not working:

Horror - Error - 400 is undefined
Action - Works OK
Thriller - Error - 1302 is undefined
Crime - Works OK
Romance - Works OK
Comedy - Works OK

I do have genres named Horror and Thriller in my Kodi movie library.

Other problems:

TV Shows button does not work - Error - MovieThumbExtension is undefined

The Movies button no longer seems to work - Error - 3171 is undefined.

However the movies button does work for me still in your original .hrp file. But I can’t see any different with the button bindings so not sure how I broke it ?

Any chance you could take a look at my project for these issues ?


Portrait-Phone.hrp (1.8 MB)

And here is the Landscape one for an Amazon Fire7 tablet.

The Movies button works in this one but it only displays a very small number of movies titles not the entire library.

Landscape-Amazon-Fire7-Tablet.hrp (1.8 MB)

This is the request I used:{“jsonrpc”:“2.0”,“method”:“VideoLibrary.GetGenres”,“params”:{“type”:"movie },“id”:1}

This works in postman


Confirming again that I have a Horror and Thriller genre listed in the database, so I don’t know why these buttons aren’t working ?

You might try the request for populating the genre in Postman to see what kind of error you get.

E.g. for Horror it is:{“jsonrpc”: “2.0”, “method”: “VideoLibrary.GetMovies”, “params”: { “properties”: [ “title”, “fanart”, “rating”, “year”, “thumbnail”, “genre”], “filter”: { “or”: [ { “field”: “genre”, “operator”: “contains”, “value”: [“Horror”] }, { “field”: “tag”, “operator”: “contains”, “value”: [“Horror”] } ] } }, “id”: 1 }

I believe that works in postman OK.

It returns information about 401 movie tiles in the Horror genre.

But did you try with a problematic genre? Just exchange 2 times “Horror” from the request.

The buttons in the Home Remote Kodi remote control page that don’t work are Horror and Thriller.

I adjusted the request for Thriller.

And that appears to work OK in postman as well return a total of 1303 and listing information about all those titles.

So this tells us my Kodi database is working as far as these two genres are concerned. The problem lies in the Home Remote Kodi plugin I think ?

Do these genre buttons all work OK for yourself ?

The plugin should use the same request as above, if I remember correctly there is a variable in the request based on the action in the button. I will check it when I get time later in the week.

As I said it’s been a couple of months since I made it and it’s quite a complicated script for someone like me who doesn’t know much JS.

1 Like

So just to confirm in one post, these are the buttons that do not work for me currently.

Movies - Popup message after pressing button = 3171 is undefined

The binding for this button says Movies.AZ

So I was expecting this Movies button when pressed, to show all my movie titles AZ ?

However it appears to be a acting as a context button for the genre buttons.
e.g. You press the Movies button first and then you press a genre button, I think.

Horror - Popup message after pressing button = 400 is undefined

If I press the Movies button first and then press the Horror button, horror genre titles are not displayed. It just seems to show titles for what ever working genre button I pressed last, but not horror titles.

Thriller - Popup message after pressing button = 1302 is undefined

If I press the Movies button first and then press the Thriller button, thriller genre titles are not displayed. It just seems to show titles for what ever working genre button I pressed last, but not thriller titles.

All the other Genre buttons seem to work OK, but only as long as initially you first press the “Movies” button for the context and then a genre button, it then displays movie titles from that genre, some movie titles don’t show cover art though.

For example if you pressed the Music button to show the albums which it does. If you then pressed a genre button nothing would change it still remains showing the albums.

So this what makes me think you have to press the Movies button first before pressing a Genre button.

And I can’t change the Romance button to the Science Fiction genre.

TV Shows - Popup message after pressing button = MovieThumbExtension is undefined

The binding for this TV Show button is Movies.TVShows

If I press the TV Shows button it does not display any TV Shows.
If I press the TV Shows button and then press a genre button it does not show any TV Shows.

Other that that I think everything is working as it should.


Doesn’t seem much is working on it :smile:. The undefined error on the genres is because it is trying to query 1 more movie than exists in your library and getting an undefined as a result. I can fix this, I’ll take a look.

So let me try breaking your questions down 1 by 1…

Removing the variables linked to the script the genre call is as below… can you check what happens if you remove “GENRE” and change to “Science Fiction” in a broswer? I can simply change in the data action as in your image and it works for me listing my science fiction movies.

http://yourip:port/jsonrpc?request={“jsonrpc”: “2.0”, “method”: “VideoLibrary.GetMovies”, “params”: { “properties”: [ “title”, “fanart”, “rating”, “year”, “thumbnail”, “genre”], “filter”: { “or”: [ { “field”: “genre”, “operator”: “contains”, “value”: [“GENRE”] }, { “field”: “tag”, “operator”: “contains”, “value”: [“GENRE”] } ] } }, “id”: 1 }

For me the following returns a result in the browser :slight_smile:{“jsonrpc”: “2.0”, “method”: “VideoLibrary.GetMovies”, “params”: { “properties”: [ “title”, “fanart”, “rating”, “year”, “thumbnail”, “genre”], “filter”: { “or”: [ { “field”: “genre”, “operator”: “contains”, “value”: [“Science Fiction”] }, { “field”: “tag”, “operator”: “contains”, “value”: [“Science Fiction”] } ] } }, “id”: 1 }


@cw-kid I just tried your phone hrp and it worked for horror and thriller genres.

Well that sucks haha


Yes it seems to work for “Science Fiction” and returns results for me in Chrome browser also. I get a massive list of results back in the web page like this snippet:

{“id”:1,“jsonrpc”:“2.0”,“result”:{“limits”:{“end”:813,“start”:0,“total”:813},“movies”:[{“fanart”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fXVID%2fFantasia%202000%20(1999)%2ffanart.jpg/”,“genre”:[“Animation”,“Fantasy”,“Music”,“Science Fiction”,“Family”],“label”:“Fantasia 2000”,“movieid”:99,“rating”:8.699999809265137,“thumbnail”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fXVID%2fFantasia%202000%20(1999)%2fposter.jpg/”,“title”:“Fantasia 2000”,“year”:1999},{“fanart”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fXVID%2fSleeping%20Beauty%20(1959)%2ffanart.jpg/”,“genre”:[“Animation”,“Fantasy”,“Science Fiction”,“Romance”,“Family”],“label”:“Sleeping Beauty”,“movieid”:216,“rating”:7.900000095367432,“thumbnail”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fXVID%2fSleeping%20Beauty%20(1959)%2fposter.jpg/”,“title”:“Sleeping Beauty”,“year”:1959},{“fanart”:“image://smb%3a%2f%2fWHS%2fMovies%2fHD%2fAlien%20Rising%20(2013)%2ffanart.jpg/”,“genre”:[“Action”,“Science Fiction”,“Thriller”],“label”:“Alien Rising”,“movieid”:2974,“rating”:4.0,“thumbnail”:“image://smb%3a%2f%2fWHS%2fMovies%2fHD%2fAlien%20Rising%20(2013)%2fposter.jpg/”,“title”:“Alien Rising”,“year”:2013},{“fanart”:“image://smb%3a%2f%2fWHS%2fMovies%2fHD%2fArea%2051%20(2015)%2ffanart.jpg/”,“genre”:[“Horror”,“Science Fiction”,“Thriller”],“label”:“Area 51”,“movieid”:2979,“rating”:4.199999809265137,“thumbnail”:“image://smb%3a%2f%2fWHS%2fMovies%2fHD%2fArea%2051%20(2015)%2fposter.jpg/”,“title”:“Area 51”,“year”:2015},{“fanart”:“image://smb%3a%2f%2fWHS%2fMovies%2fXVID%2fInfini%20(2015)%2ffanart.jpg/”,“genre”:[“Horror”,“Science Fiction”,“Thriller”],“label”:“Infini”,“movieid”:2983,“rating”:6.0,“thumbnail”:“image://smb%3a%2f%2fWHS%2fMovies%2fXVID%2fInfini%20(2015)%2fposter.jpg/”,“title”:“Infini”,“year”:2015},{“fanart”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fXVID%2fHome%20(2015)%2ffanart.jpg/”,“genre”:[“Animation”,“Comedy”,“Fantasy”,“Science Fiction”,“Family”],“label”:“Home”,“movieid”:2985,“rating”:7.099999904632568,“thumbnail”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fXVID%2fHome%20(2015)%2fposter.jpg/”,“title”:“Home”,“year”:2015},{“fanart”:“image://smb%3a%2f%2fWHS%2fKids%20Movies%2fApple%2fAliens%20In%20the%20Attic%20(2009)%2ffanart.jpg/”,“genre”:[“Adventure”,“Comedy”,“Fantasy”,“Science Fiction”,“Family”],“label”:“Aliens in the Attic”


Like wise if I change the “GENRE” to either Horror or Thriller it seems to work OK in the browser and returns results.

Could it be the sheer amount of results that is the problem ? I have a large movie library.