Netatmo Energy and Weather are dead

Hello,

All Netatmo modules are dead. Is it possible that the Netatmo API is cut? The Netatmo applications work well though.

Something may be wrong with HR because Netatmo works on apps, through the web, and with Fibaro. But more on HR. As if the last version did something? It does not work with the HR emulator either … However the authentication to the API from the designer works, but no data is returned for the heating or the weather.

Is it only broken in your project? Do new projects work? Do the built-in app integrations work (no Designer HRP files)?

I’m not currently experiencing this issue. You may have to reauthenticate. Go to the Settings page & select your Netatmo account then click the Save button. That should validate your access tokens.

If you’ve made several attempts & it is still not working I will gladly look into it. Please add me a user to your system. My Netatmo email is support@thehomeremote.com

From scratch. Do not work.

NetAtmo weather and Heater app OK
Fibaro OK
Chrome desktop OK

Home Remote NOK

I did the test in the application, without going through the Designer. I completely erased the configuration and deleted the application then I installed the application and only connected my Netatmo account like the images above. It’s broken with HR. You received 2 accesses by email, 1 for the weather and 1 for the heating. I want to clarify that here in France, there are a lot of complaints towards Netatmo on the servers, the devices no longer work for most people. I am fortunate to have my system still working. To dispel any doubt about the API I went to see my Fibaro box and the Netatmo plugin also works. On HR it has always worked, but since the last update of the application it no longer works. What I find strange is that the Designer simulator no longer works with Netatmo either.

After going online with your thermostat, I was able to find the issue. This will be fixed in the next 3.19.0 release. It has nothing to do with the most recent Home Remote update. Even if you were to rollback your HR apps to the prior version it still wouldn’t work.

They seem to have made a very minor API change. Instead of returning a 0 for therm_setpoint_end_time when it isn’t being used, they are now not returning the property at all. Which is perfectly fine. They probably don’t need to return that when you are following schedule. It’s just that the Home Remote is currently trying to access that field regardless of the thermostat mode. I’ve made a change so that they next release will do a conditional check & only try accessing it when available.

That being said, the integration will work for you currently if you were to take your thermostat out of schedule mode in the Netatmo app & apply a manually adjusted setpoint. Basically, if that setpoint timer has a value, it should work. That obviously isn’t a long term solution so I will try to get the 3.19.0 fix posted in a few days.

1 Like

thanks bill for the investigation and resolution soon. I just realized that when the manufacturers modify their API it is very complicated to follow because not documented and the third parties are not kept informed of the changes. wow!

Hi Bill, thanks for the update

The boiler thermostat is working.

But some readings at Netatmo do not work on the Weather Station part.
For example what is relative to TemperatureMeasurement, TemperatureRange, CarbonDioxideMeasurement if I do a Bind of the device.

But if I look on the detail tile corresponding to WeatherStationDetails1.xaml then I can see the temperature very well as well as the CO2.

A bind of the device as in the photo does not work on several parameters indicated above.

Here in the template the display works.

I don’t know if it’s the accents that bothers me, I’ve always had the accents before and it worked well with the remote.

Do the readings work with the default templates?

Please do this for me:

  1. Create a new project
  2. Add your Netatmo devices
  3. Add your Weather Station to HomeGroup.
  4. Start the Simulator.
  5. Click the Weather Station device tile so it opens the details page.

Hello Bill,

EDIT : Apologies Bill, after investigating the problem is on my work machine, I have recently turned PiHole back on and it is (I presume) the source of the problem. I deleted the PiHole DNS present on my machine and everything is back to normal.

This was my answer before I found the error.

Nothing appear :frowning:
and today, the boiler thermostat no longer works either.

image



image

On Fibaro HC2 it work
image
image
image

Hello Bill,

It seems that Netatmo has changed the API again because my values have disappeared again.
Maybe they did a rollback?

I have seen this for 7 days.
With the change you made everything was fine, and now it starts all over again :frowning: I left a new project for testing. Nothing.

You are probably having the same issue that was reported here last week. Netatmo Energy is no longer sending “battery_level” when batteries are fully charged. That’s causing the integration to break because it’s trying to read something that isn’t there. This will be fixed in the 4.1.5 release. I plan to create the builds today & start uploading them to the stores.

Hello @bill

Work fine now !
Many thanks !

Bernard

1 Like