Problem creating device browser

I have watched just about every video I can find on this issue but I still cannot figure out what I am doing wrong. I have specifically been viewing Johns video about Device Browsers. You can see in the two screenshots what I have setup. The issue is once I have it all setup, or so I think, the buttons I have created do nothing. Interestingly though, if I click the IsChecked box in one of the buttons properties pages then that particular page and devices will automatically populate in the device browser. I feel like this issue is the button connecting to or sending the command to the device browser or the device browser receiving the command. I am an extreme novice when it comes to this so please dont beat me up too bad.
Thanks for the help.

Based on the info you’ve provided it should work. Would you mind uploading your project? Please be sure to clear out your Vera credentials. I don’t need those.

Any reason you are not using a TabbedPage? Looks like that would be a better fit for what you’re trying to build. See attached example.

hoggin.hrp (82.5 KB)

First, thanks for the quick response.
Second, I tried to upload the file but since Im a new user I think there is a limitation on that.
Third, there is no reason I am not using a TabbedPage other than I really didn’t know how to do it!!
Lastly, I have spent so much time on this device browser that I kinda still want to know what I am doing wrong so I can learn this program. Now its just a challenge.

Ill try to send it to you directly (if thats even possible) and then you can post so others can learn from it.

Cant seem to find any other way to get this file to you. Perhaps you have an idea?

Email it to me at support@thehomeremote.com I’m going to be away for a little while today but I’ll try & look at it later.

Sent. Take your time!

Found the issue. You forgot to set the ButtonType to Toggle.

Another way to create this is to use a GridView. It’s a little cleaner & easier to configure. I’ve attached a revised project that replaces your 3 buttons with a single GridView.
Try4_GridView.hrp (84.7 KB)

Thanks for this. I changed them all to toggle but when I do that I have to unclick a button when I want to go to the next one. I cannot simply click lights then temps then locks. It makes me unclick or untoggle the button for it to function correctly.

I had no idea that the gridview function existed but it appears to be nice and quick and also cleaner. What would be the benifit of one over the other?

You needed to set them to Toggle because the Triggers on your DeviceBrowser were dependent on the IsChecked property for the Buttons. That property is only available for Toggle buttons. Your other option would be to remove that dependency & simply set the DeviceBrowser Group with a Click EventTrigger for the Buttons. There are always going to be 100 different ways to do the same thing. Choose the option that makes the most sense to you.

Got it. I think Ill stick with your suggestion. Problem now is it wont load into the app. I can run the simulator and it works but when I upload to Google Drive and restore from the app it crashes at startup.

Try opening the file from Google Drive with the Home Remote app closed. Sometimes it works better to load the HRP with the app closed. Or try another storage option. What almost always works is emailing the file to yourself & then clicking the file in the Gmail app. Try that too.

…and some Android devices don’t always recognize the HRP file extension. Another thing you can try is changing the .hrp to .zip

I have to be honest. I have tried every conceivable combination out there. I emailed it to myself in both formats and google drived it too in both formats and I can get it to appear as if it loaded but the app crashes every time. I can load a simple file and that works but I feel like if there is device browser then it wont load. To test this I simply deleted the device browser from a previously unloadable config file and it loads so this must be the issue. Any ideas?

Here, try this file. I made a few tweaks to your project. The DeviceBrowser either needs to be given an absolute Height & Width or it needs to be part of the root Grid. When nesting in child grids issues like this can come up.

Try4_GridView (3).hrp (84.7 KB)

I notice you also had an invalid ColumnSpan assigned. That can also cause problems. You had the ColumnSpan set to 2 but you haven’t created 2 column definitions in the parent Grid. You need to watch out for that.

Here’s a file that fixes your invalid ColumnSpan & assigns a size to the DeviceBrowser. If you don’t wish to assign a fixed size then use the file attached in previous post.
Try4_GridView (5).hrp (84.7 KB)

That worked like a charm. I moved the browser on another one I was working on and that made all the difference. Thank you for your help with all of this. Is there a better way for me to learn about this besides starting a topic or is there limited documentation at this point?
Again, thank you for all your time spent!

Another problem. When I try to click on the lock in the device browser it will not actuate the lock but when I enable Isgroupsvisible and click on this lock through one of those menus I can actuate the lock. Any ideas on this one?

Which button are you clicking on the tile, “LOCK” or “UNLOCK”?

Documentation is a bit limited. Watch the YouTube videos. They go into a lot more details.

First I select locks in the grid browser Then I attempt to press the unlock button and it’s as if the whole tile is not interactive. No matter where I press it doesn’t change or anything.