RTSP on Android

For anyone interested, RTSP on Android was completely redone in the 3.6.0 release. The previous versions used the stock Android VideoView for RTSP streams and that presented major issues for a lot of people because it doesn’t support authentication. There were also many reports of standard unauthenticated streams having huge delays. For me myself, my old Samsung Techwin cameras used to have about a 10 second delay on Android. Now it’s close to realtime. The new implementation isn’t perfect but it at least works for the most part. Right now it’s video only. Audio frames are ignored. That’ll be a future enhancement.

1 Like

YES! This is amazing. I’ve got 9 cameras using a bloated mjpeg second stream to use in HR with a 4 per second frame rate lol. Super pumped, thanks.

1 Like

Could you please send an example or point to a link about how to configure the IP cameras to use RTSP? Many thanks!

Not all cameras support RTSP. You’ll have to check the documentation for your camera to see if they provide an RTSP URL. And I generally recommend users 1st test their URLs in VLC media player to verify they in fact work.

I tried in Windows Media Player and it works! According to the user manual:

"This requires AXIS Media Control and the H.264 decoder to be installed. The following paths can be used:

  • Unicast via RTP: axrtpu:///axis-media/media.amp
  • Unicast via RTSP: axrtsp:///axis-media/media.amp
  • Unicast via RTSP, tunneled via HTTP: axrtsphttp:///axis-media/media.amp
  • Multicast: axrtpm:///axis-media/media.amp"

Do you mean “rtsp://axis-media/media.amp”, not “axrtsp:///axis-media/media.amp”?

I found where you got that. Read below it. There are traditional RTSP URLs you can use too. Use those. Don’t use those Windows Media Player ones.

It does not work, I tried Chrome and Edge browsers. I have installed Axis Media Control and H.264 Video Decoder as instructed by the manual. Do I need to install something else?

RTSP will not work in a web browser. Try VLC .

OK, actually I tried with Quicktime and it works

i installed VLC and both options also work, “rtsp:///axis-media/media.amp” and “rtsp:///axis-media/media.3gp”

Great! Now add a new IP Camera device. For URL Search select “Manual” & for URL paste your RTSP URL.


When I add an IP Camera I get a different form than the one you show above?:


How can I get the right form?
Many thanks.

You need the latest version which is It looks like the upload to the Microsoft Store is stuck in the certification phase. It seems like those builds sometimes take a week to be accepted. Just uninstall what you currently have & download it from the website. Here’s the link:

Doesn’t seem to work for me.

In HR designer I added a new IP camera device object and entered the correct details for my cameras RTSP stream.

In the designer in the app emulator it works, I see a preview on the tile and when I click the tile it opens the cameras video OK.

However when I save the hrp file and import on to the Android app, I just get a black square for the tile no preview and if I click the tile I just get a black screen.

I then tested my RTSP URL in VLC on the Android phone and that works fine.

Phone is Android 9 Pie.


The stream has to be H.264 or it will not work. Check the “Tools -> Codec Information” menu in VLC to see what type of stream it is.

The button “Get the app” of the link does not do anything ?

You should see a popup “Open App Installer”. Do you have Windows 10 version 1709 or newer installed?

If you are running an older Windows version you may need MSIX Core.

I have the latest version 19041.450. I saw the popup and clicked the button but nothing happened, then I also checked the check box and now nothing happens,

Whenever you click “Open App Installer” it should open a new window like the one below.

Check to make sure App Installer is installed:

Uninstall all of your old versions of the Home Remote. It’s possible that’s creating a problem.

Are you running any 3rd party antivirus software? They may be preventing App Installer from opening.