Set Local Repository for HRP (for members of local group))

Modify app so that it can be set to “watch” a specific location on a local network. Whenever a HRP at that location is newer than the HRP currently loaded on that device, a message will pop-up inviting the user “restore” (load) the newer HRP.

There are five (mostly childish) adults who live in this home and all of them need to use the Home Remote app with a common (family) HRP. I can see a lot of security reasons why it would be at least a challenge to push the revised HRP down to devices. But a nag message with an easily clicked message inviting family members to restore/load the newer HRP would make my job as the family HR dev a lot easier. In my case I’d set everyone’s app to watch \myserver\home_remote. Distributing updates would be much easier.

This is already available. Go to the Publish tab & configure FTP. You will have to load the initial file like normal but all following loads can pull the file from the FTP server you’ve configured.

1 Like


This is great news. Sorry that I didn’t notice it already existed.

Now I have to figure out how to have one of my FreeNAS fileservers also act as a FTP server to serve up specific dataset destination with accepting anonymous credentials. I know that there’s a way to get FreeNAS to do that, but it’s not something I’ve ever used before. I mean, I use FTP (actually SFTP) every day, but only as a client connecting to a server maintained by someone else.

Bill wrote, “ You will have to load the initial file like normal but all following loads can pull the file from the FTP server you’ve configured,

What I failed to grasp from Bill’s comment is this:

  1. The first time that you “publish by FTP” (and provide the site, username and password) within the Designer application, it will embed those details in your HRP file.

  2. After you have “published by FTP” you need to go to the FTP server and save that HRP in conventional ways and then load it the old fashioned way (one time) on every phone or device in your family / group.

  3. Each phone / device will see that the new FTP details are in the HRP. From that point forward, each device will use those details to check the FTP server to see if there is a newer HRP there. If yes, each phone / device will automatically connect, download and install the new HRP. You will never need to manually load (“restore”) an HRP file ever again.

In 3.11.1 I get an error dialogue when restoring from an FTP resource…

(I have no reason to believe this is a 3.11.1 specific issue, I haven’t tried on any earlier versions)

"Error (

Value cannot be null.
Parameter name: value"

Seems to all work ok in simulator and also in the Android app (same file as on the ftp server). Home remote designer publishes just fine (using anonymous user) to my local FTP server (QNAP).

Any ideas?



I just did a test on my server & everything appears to be working correctly. The “Quick Publish” button in the Designer copies the file to the FTP server. The “Restore” button in the app grabs the new file.

The only difference is I’m not using an anonymous user. I have a username & password. Maybe try adding credentials.

Hmm. Tried using credentials but the same error appears. I do notice that if I go back to edit the credentials I see what looks like an autogenerated password. Is that expected? (maybe a hash or something). I’ll try some more testing over the weekend (midnight here now). Thanks for checking your end.



It could be your project. I’m just testing a very simple one with just a single page & a single label.

That password you are seeing is the encrypted contents. That is a bug, but it’s not causing your issue.

Try my project & see if it works for you. That’s the 1st thing I’d look into.
FTP_Test.hrp (7.2 KB)


I created a separate ftp folder on my server with what I think is the same options as before apart from removing anonymous access. I added user credentials to the Home Remote designer and now the Android app works without error. Prior to doing that I did retry just adding credentials but that didn’t do it. I’m not sure what exactly changed but I’m glad to say things now work. I’m too tired to reason this out, so I’m going to handwavingly say it must of been server config.

Thanks for sparing the time to create a test project anyway.



1 Like