Very unstable with Homeseer

Hi all,

New here but one of the Imperihome orphans looking for a new home.
I’ve been using Imperihome, HSBuddy and Homeseers own app without any issues in terms of connectivity however having recently started to dabble with THR, I’ve hit a stumbling block quite early on and this is stability.

This is purely in Designer currently.

  1. I can almost never use my ddns ( although every so often it will work without issues. Other times I get an error:
    I will put this in as soon as it happens again - typically I just switched from IP back to the name and its worked.

  2. Having said the above, even with IP address it does seem to almost “lose connection”

So while I’m typing this, the connection seems to have dropped again. Steps I did was:

  1. Added and binded a toggle switch to a light
  2. Started simulation
  3. Hit toggle switch and it toggled across.
  4. Toggled back and got “an error has occured”
  5. Went to re-sync devices under >Homeseer and I get “An error occured while sending the request” (same as the toggle)

Switched to IP, sync devices, worked fine

I’m very new to this (an hour or so in!) so maybe its me…?

thanks in advance

“An error occurred while sending the request” typically occurs when the server can’t be reached. So there could be an issue accessing the system with DDNS on this PC. Although that’s a pretty general error though so it could be something else.

Are you really seeing that exact same error when using your local 192.168.X.X address?

Also be sure to uncheck the MyHS option if you don’t plan on using it.

Any chance this is a HS4 system?

Read these posts because they may help:

Thanks Bill - good to “meet you” and great product!

Sorry I was a little vague in areas juggling this and a 1 year old!

In terms of error, in both cases, it was the same error. Just carried out the steps word for word as per below:

  1. Right click Homeseer>Sync
    1a: Do you want to sync devices? (Yes)
    All ok

  2. Run simulation which just has a toggle + label from one of the training videos. Correctly shows light as “off”

  3. Toggle on = An error occured while sending the request

  4. Stop Sim

  5. Right click on Homeseer>Sync
    5a: Error: An error occured while sending the request

  6. Flip to IP and pretty much line for line its the same.

I wonder if my Toggle is breaking something indirectly - I know I’ve not finished it and currently does nothing but does has a binding. I might just be too focussed on connection

It is a HS4 system however I am using iP/ddns and not MyHS account (intentional)
Credentials are fine as per test links.

Let me play more and get the toggle switch completed

I know HS4 itself is absolutely fine and the web UI + all 12 tablets + 12+ alexa devices communicate fine with it at the same time as THR reporting an error - this is using a mixture of ip and my name.

There may be an issue with your toggle. If you want to email me your project I can look it over to see if I can find the issue. My email is

Or, look over this attached Tile template I designed for you. Copy it into your project & assign it to your device’s TileTemplate property. It uses a ToggleSwitch instead of the default actions.

CustomToggleTile.xaml (2.2 KB)

Thank you very much - the template helped a lot and I am pleased to say I got the toggle working.
What I can’t get working is the “status” of one the of devices I assigned to the toggle.

My assumption was to bind it to HSStatus or HSValue but neither worked although when I was testing yesterday on another device, it did bring back the status/value for that one.
If Homeseer reports back as “on”, what element does that talk to ?

BUT and more importantly, I tracked down the “instability” issue.
I noticed once again when the light switched on, I lost connectivity with THR and Homeseer - had an idea, looked at the HS4 log and sure enough, my IP got banned as part of the “Enable IP Hack Blocking” in Homeseer.

Now the question is, what is THR doing that is causing the block?
Authentication can’t be the issue given it works the once or twice before getting blocked

My suggestion is to add 2 Labels to your page & bind one to @Device.HSStatus & the other to @Device.HSValue. Those are really the only 2 fields read in from HomeSeer. Everything else like @Device.Switch is derived from either HSStatus or HSValue. So monitor those 2 attributes to find out which one you need to use.

I am unfamiliar with “Enable IP Hack Blocking”. I think this is more a question for HomeSeer. You will probably need to reach out to their support staff.

Thanks Bill - in this case, both HSStatus and HSValue did not bring back anything so it might just be the device in question. Will play around and see what happens providing I don’t get blocked each time.

So IP Hack Blocking is enabled by default in HS and a very old article on the HS forum explains it as per below…
The fact Imperihome, HSBuddy and their own app is not blocking it seems to suggest the designer app is pinging it bad credentials from whatever machine I am working on - ie, my laptop ip was blocked but then when I moved onto designer on my PC, that IP got blocked.
I’ll try and disable it just to see if the HS logs capture anything meaningful and dig around in the project although connection-wise, I only have Homeseer and Honeywell added.

Given no one else has complained - they either have switched off IP Block or it could be something in the latest HS4 version or indeed, in this project/THR.

Thanks again for the help - I’m going to look around for some downloadable templates as my creativity is non-existent!

HomeSeer’s Hack-Block protection tracks how often an object
(web page, graphic, etc.) is requested of the web server from an IP
address that has not successfully authorized access to the system. If
enabled, and the number of unauthorized object requests (‘hits’) that are
received within the specified interval exceed the threshold specified, then
that IP address is blocked from communicating with the web server for the
block time specified.

Just out of curiosity, is Hack Block protection turned on by default? What’s HomeSeer’s default value for this setting?

Don’t forget about the default templates either. I usually recommend people start with the apps 1st & export a Backup. Then open that Backup with the Designer. This way you have a completed project that you can edit & customize.

Hi Bill,

I am going to say it is ON but now thinking about it, I’ve had HS for a number of years and so it is likely I enabled it at some point and the setting has then come across. I’ll try and do a local install of HS4 and see what it is.

I did switch it off today while I’ve been playing and so far it has been working without any blocking so I may just leave it off for now.
Have asked in the HS forums about it as the preference is to have it on but if its just going to cause issues…

As for templates, thanks for the tip! I was more talking about the look and feel as per some of the showcase threads. I feel once I have a skeleton structure, I can start adding the guts (devices etc)

Today has mainly been going through all your YT videos, and spending a number of hours on Sweet Home 3d to get get the house drawn up as I thought it was an excellent way of showing various devices using the house itself.

Also played with toggles/sliders etc and now understand how they work.

So now its just to get hopefully a bare-bones template and add to this.

Could I ask what is probably a silly question and maybe an issue too?

If I created Page1, Page2, Page3 under pages and hit the simulation, I only ever see the first one despite maybe working on page2.
Am I missing something here?

And the issue…
I have found a number of times if I double click on a page in design view, it does not open this page up and sticks to the first page. Only way around it is to close designer, reopen the project and then go straight for the double-click on the page2.

Appreciate this is going off-topic now so happy to open another and consider this resolved/somewhat user error (ip blocking)

The simulator uses the current selection in the navigation menu to decide which page to display. Look at that menu to see which item is selected. For example, in the screenshot below, Page2.xaml will be shown when I start the simulator.