No Response From Global Cache on iPhone iOS

Does using a Global Cache (iTach IP2IR) in THR only work with the Pro version, or am I missing something? The iTach works perfectly in the Designer simulator. However, I get nothing when testing on an iPhone (IOS 17.3.1). Laptop (Designer) and iPhone (THR) are connected to the same network. I can log into the iTach’s web interface from the iPhone. Additionally, using the “SettingsReset.hrp” on the iPhone to test, when adding the Global Cache device, it will time out. iTach IP2IR is using the latest firmware.

Maybe you can find here a solution:

@KalleVC - Thank you. However, I already read that post.

Testing with the Designer, using the simulation mode, everything works fine, and commands are sent to the Global Cache iTach (IP2IR) and those commands are transmitted to the end devices (TV, Soundbar, Set top box, etc.). That tells me that the Global Cache iTach’s configuration and the selected code sets are correct. The IR blaster is in range and hitting the IR receivers.

Regarding connection limits, I am not using a Global Cache GC-100. I am using a Global Cache iTach IP2IR which supports 8 connections according to the link provided and the document “API-GC-UnifiedTCPv1.1.pdf”. At worst I would only have 6 connections.

  1. The Windows laptop for development using THR Designer’s Simulation and using my “custom.hrp”
  2. The Windows Laptop using Firefox to access the iTach’s web portal.
  3. The iPhone using THR and my “custom.hrp” (which fails!).
  4. The iPhone using THR and the " SettingsReset.hrp” which gives me a time out error when trying to add a Global Cache device.
  5. The iPhone pinging the iTach to verify connectivity (would be a momentary connection).
  6. the iPhone accessing the iTach’s web portal.

Assuming that none of the connection were released. Furthermore, the failures start before the ping and portal access. Realistically I would have had 3 concurrent connections.

Hi Lonny,
You have given a detailed report. Do you have the opportunity to test it on another mobile device?
I once had a similar situation where the buttons worked perfectly in the simulator but not on the iPad. The problem was that the buttons were somehow in the background. You could see them on the iPad but they didn’t send the command when clicked - but it worked in the simulator.
Can you create a new blank page in the designer and create a button with an iTach command that changes colour when clicked to see if it’s not this problem?

Thanks Kalle.
Great suggestion! A single button still failed. However, the second link was helpful. After painfully side-loading THR on an old Galaxy Tab-S, I used the default configuration, leaving out the designer. I added the Global Cache device, and it connected and installed a device to control. The default buttons all worked. So, I loaded the custom HRP, and it worked, too. I ended up wiping the iPhone and repeating the process I followed with the tablet. Everything seems to be working, even after spending hours re-installing apps and configuring the phone. Thanks again for the help!

You are welcome :wink: